Las nuevas versiones de navegadores y el SAT.

Como publicamos en nuestro sitio hermano, los complementos de software, comúnmente llamados plugins, que permiten la reproducción de juegos flash, videos de youtube, los applets de Java, el streaming en Netflix y sitios similares están en fase de extinción. Son una tecnología vieja, obsoleta y que abre la puerta a posibles fallos de seguridad, por lo que fue reemplazada con la ahora popular tecnología HTML5. Podrás encontrar amplía información aquí.

Con respecto a ello, Firefox era el último navegador que permitía aún la compatibilidad con estos componentes. Pero con el lanzamiento de la versión 52, este soporte ha quedado sin efecto, por lo que ya no es posible ejecutar estos plugins. ¿En que te afecta? en mucho, por que estabas acostumbrado a no tener problemas con ello, pero hablaremos exclusivamente del sitio del SAT.

Muchos recordarán que era y sigue siendo un dolor de cabeza acceder a las páginas del SAT por que era común que apareciera este mensaje:


Y solucionarlo era una verdadera proeza, aquí mostramos como solventarlo. Sin embargo, si la página del SAT funcionaba correctamente en tu equipo, después actualizaste tu navegador y ahora intentas acceder al sitio con tu e.firma, ya no hay mucho que se pueda hacer, puesto que el soporte para applets ya ha sido descontinuado.


Es de mencionar que esto iba a suceder tarde o temprano y el SAT lo sabía, por ello se apresuro a crear un acceso que fuera compatible con tecnología HTML5, y tal como se puede apreciar en el portal de consulta de los CFDI’s.


Esta nueva página de acceso solo requiere tu FRC y contraseña, sin utilizar los sellos, que si bien dan más seguridad, el applet que los validaba ya no es posible ejecutarlo en las nuevas versiones de los navegadores.  Este cambio obligado sin duda representa una simplificación para cumplir con el SAT ya que muy pocos contribuyentes son entendidos en el ámbito informático y se frustraban al no poder echar a andar los sitios en su equipos.

  1. Ante todo esto, te dejamos una lista de recomendaciones para no tener problemas con el sitio del SAT.
  2. Actualizar tu navegador es una buena práctica, nosotros recomendamos ampliamente Firefox, que está disponible para Linux, Windows y OSX.
  3. Para acceder a los sitios del SAT, usa los accesos que no requieran la e.firma.
  4. Ya no es necesario que estés actualizando tu versión de Java, a menos que otros sistemas que utilices lo requieran.
  5. Si actualizaste tu navegador y aun requieres usar plugins en el, utiliza la versión ESR, que por un año más te permitirá usar aún los plugins, sobre todos si tienes sistemas propios que deban utilizar applets u otro tipo de complemento.
  6. Si tienes un equipo con Windows XP, los navegadores ya no se actualizan sobre esta versión de OS, por lo que quizá el impacto para ti sea nulo, pero considera esta guía si llegas a actualizar tu sistema.

Si tienes dudas o comentarios, no dudes en usar la sección de comentarios y responderemos a la brevedad posible.

¿Te fue útil este artículo? Por favor, califícalo.

[Total:1    Promedio:2/5]

 

About Héctor Hernández

Ingeniero de Software, experimentado desarrollador. CEO y fundador de BytesMX. Adicto al café (de olla). Solo compartiendo lo que sé.

2 thoughts on “Las nuevas versiones de navegadores y el SAT.

  1. Quiero facturar con. El nuevo sistema del sat actualizado en julio y no puedo grabar cliente solo pude en el google chrome pero al final no me deja sellar me aparece instalar silver light y no c puede y en los otro navegadores cuando elijo el cliente de la lista no lo carga y no puedo continuar con la FAC habrá una forma de solucionarlo si me puede ayudar

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *